OpenWRT en Zabbix - Best friends

De TP-Link Archer C5 v1 is via de default firmware niet te monitoren via Zabbix. Sommige van zijn kleinere broertjes hebben SNMP, maar hier kon ik alleen maar naar pingen. Die dagen zijn voorbij door gebruik te maken van OpenWRT.

Firmware

Via de web UI kan je de nieuwe firmware gaan updaten.

Download de firmware afhankelijk van de versie (kijk op de sticker onderaan je toestel) en zet die op je router.

Meer info en downloads zijn te vinden op de website van openwrt.org

Minimal config

Sluit een computer aan op één van de LAN-poorten op de router (als je dat al niet had gedaan).

Na het flashen zal de router spelen als DHCP server en IP-adressen uitdelen in de range van 192.168.1.100 tot ...
Mocht je geen IP-adres hebben gekregen stel die dan handmatig in op bv 192.168.1.254 met gateway 192.168.1.1 (IP van de router).

Pas de configuratie aan van de router via SSH (bv met Putty).

Onderstaande gegevens geven je een opsomming van de belangrijkste settings. De router functies worden niet gebruikt.

Vb: netwerk config met vast IP 192.168.0.102, gateway 192.168.0.1 en interne dns server 192.168.0.2 (je kan uiteraard ook kiezen voor externe dns 8.8.8.8)

vi /etc/config/network
config interface 'lan'
option ifname 'eth0'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.0.102'
option netmask '255.255.255.0'
option gateway '192.168.0.1'
option dns '192.168.0.2'
option ip6assign '60'

Het wireless gedeelte, kan ook later gedaan worden

vi /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'pci0000:01/0000:01:00.0'
option htmode 'VHT80'
option txpower '17'
option country 'US'

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'psk-mixed'
option key 'een-sleutel'
option ssid 'Reynaert AC'

config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/qca955x_wmac'
option htmode 'HT40'
option txpower '24'
option country 'BE'

config wifi-iface
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'Reynaert N'
option encryption 'psk-mixed'
option key 'een-sleutel'

Het uitschakelen van dhcp

vi /etc/config/dhcp
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option localservice '1'

config dhcp 'lan'
option interface 'lan'
option leasetime '1'
option dhcpv6 'disabled'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'

Geef je AP een naam

vi /etc/config/system
config system
option hostname 'AP-Reynaert-102N'

Optioneel: Luci, de web UI

Door je AP te configureren via SSH, kan je toestel perfect werken. Maar om het je gemakkelijker te maken kan je een Webbased Interface installeren. De meest bekende is Luci.

Nog steeds in de SSH console:

opkg update
opkg install luci

Je kan nu browsen naar het IP-adres van je router. bv http://192.168.0.102/

Zabbix agent

Je zou SNMP kunnen installeren (of misschien doe je dit straks als extra erbij). Maar er bestaan een zabbix packages die dezelfde functionaliteiten geven als de pre-compiled agents, zoals die te vinden zijn op http://www.zabbix.com/download.php

De packages zijn te vinde op de openwrt site. (via http of https)

wget --no-check-certificate https://downloads.openwrt.org/latest/ar71xx/generic/packages/packages/zabbix-agentd_2.4.6-1_ar71xx.ipk
wget --no-check-certificate https://downloads.openwrt.org/latest/ar71xx/generic/packages/packages/zabbix-agent_2.4.6-1_ar71xx.ipk

wget --no-check-certificate https://downloads.openwrt.org/latest/ar71xx/generic/packages/packages/zabbix-extra-mac80211_2.4.6-1_ar71xx.ipk
wget --no-check-certificate https://downloads.openwrt.org/latest/ar71xx/generic/packages/packages/zabbix-extra-network_2.4.6-1_ar71xx.ipk
wget --no-check-certificate https://downloads.openwrt.org/latest/ar71xx/generic/packages/packages/zabbix-extra-wifi_2.4.6-1_ar71xx.ipk

opkg install zabbix*

Pas de config aan, ServerActive en Hostname zijn minimaal aan te passen.

vi /etc/zabbix_agentd.conf
ServerActive=IP-Zabbix-server
Hostname=OpenWRT-router

Start en enable de agent, kijk of het process zabbix_agentd te vinden is

/etc/init.d/zabbix_agentd start
/etc/init.d/zabbix_agentd enable
ps

Zabbix Template

De template heeft als basis deze van Template OS Linux (default template van Zabbix) met twee extra Low Level Discoveries voor Wifi en Mac80211

Template is te vinden op pastebin.com

Terug naar overzicht nieuws